# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*([,\h])(?1)*/$1/gm;t' <<< "first , second ,, , , third, ,fourth suffix ,, more"