package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h*([,\h])(?1)*`)
var str = `first , second ,, , , third, ,fourth suffix ,, more`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}