// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:t|tg|telegram)(?:\.|:/)(?:me|dog|)/(?:\+|joinchat/|join\?invite=)?([\w-]+)").unwrap();
let string = "t.me/+TuxVLdSmj1RiMTEy
t.me/joinchat/TuxVLdSmj1RiMTEy (legacy)
tg://join?invite=TuxVLdSmj1RiMTEy
telegram.me/+TuxVLdSmj1RiMTEy
https://t.me/test_bot";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}