$re = '/\b([a-zA-Z0-9-._]+)@[a-zA-Z0-9-]+(\.[a-zA-Z0-9]{2,})+\b/m';
$str = 'name.surname@gmail.com
anonymous123@yahoo.co.uk
my_email@outlook.co
johnsnow@gmail
anonymous123@...uk
myemail@outlook.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);