$re = '/\s*\b\d+\b\s*/';
$str = '1519 KINGSCROSS RD';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;