using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?P<key>[A-Z]+)=("")?(?P<value>(?(2)[^""]*|\S+))";
string input = @"update DIFFICULTY=1 DESCRIPTION=""some long run on description""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}