#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]-(?=[A-Z]))|([A-Z](?=[0-9])|[0-9](?=[A-Z]))"
Local $sString = "A-BA -> ABA" & @CRLF & _
"A-B-BAB -> ABBAB" & @CRLF & _
"" & @CRLF & _
"9AHYA7 -> 9-AHYA-7; " & @CRLF & _
"977AB99T5 -> 977-AB-99-T-5" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"HS98743YVJUHGF78BF8HH3JHFC83438VUN5498FCNG" & @CRLF & _
"7267-VHSBVH8737HHC8C-HYHFWYFHH-7Y84743YR8437G"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")