import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w]+);([\\d]{2})-([\\w]{3}|[\\d]{2})-([\\d]{4});([\\d]{2}):([\\d]{2}):([\\d]{2});([\\d]+);(?(?=[\\w]*;)([\\w]*);|)((?:([a-zA-Z0-9_@.#\\/&+\\(\\)\\-\\\\!$%^*=',.<>?\\{\\}\\[\\]`~:\\| ]+)[ ]*[-][ ]*([\\d]*);)+)([\\d]+);";
final String string = "SGH;02-FEB-2017;02:02:02;200;buah -1;3;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}