#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\n\r\t:]+(?=:(?:.*\R\t)*status:\h+active)"
Local $sString = "ABC 12:" & @CRLF & _
" text...." & @CRLF & _
" text......." & @CRLF & _
" status: active" & @CRLF & _
"XYZ 34:" & @CRLF & _
" word word word" & @CRLF & _
" status: active" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")