import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\n\\r\\t:]+(?=:(?:.*\\R\\t)*status:\\h+active)";
final String string = "ABC 12:\n"
+ " text....\n"
+ " text.......\n"
+ " status: active\n"
+ "XYZ 34:\n"
+ " word word word\n"
+ " status: active\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}