$re = '/(?:(?:Mike: )((?!.*_keyword).*))[\s\S]*(?:(?:Sonya: )((?!.*_keyword).*))/';
$str = '..some_text_and_linebreaks..
Mike: Using some_1eyword
..some_text_and_linebreaks..
Sonya: Using another_1eyword
..some_text_and_linebreaks..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);