$re = '/(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))/mx';
$str = 'Don\'t match:
{secure]
{spatula}
secure[(secure])
~secure~
Match:
[secure]
*ENCRYPT*
{EnCrYpT}
(sEcUrE)
Secure or Encrypt within *,{, [ or (';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);