# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^\h*<!--|(?<!\A|-->\n)\G).*\R/\n/gm;t' <<< "<!-- text1
text2
text3
text4
-->
ext
text"