const regex = new RegExp('(?:^\\h*<!--|(?<!\\A|-->\\n)\\G).*\\R', 'gm')
const str = `<!-- text1
text2
text3
text4
-->
ext
text`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);