use strict;
my $str = '<link href=\'G:/Using/mdCss/style.css\' rel=\'stylesheet\' /> More words
<link href=\'./style.css\' rel=\'stylesheet\' />
<!-- some random header info -->
<!-- ctrl a dont select above -->
This is the content.
Some random sentences.
More content with <link in it';
my $regex = qr/^(?!(<link|<!--)).+$/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";