import Foundation
let pattern = #"^(?!(<link|<!--)).+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<link href='G:/Using/mdCss/style.css' rel='stylesheet' /> More words
<link href='./style.css' rel='stylesheet' />
<!-- some random header info -->
<!-- ctrl a dont select above -->
This is the content.
Some random sentences.
More content with <link in it
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)