#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(.+?) ?\b(\d{4})\b(.*?)$"
Local $sString = "Visiting relatives 2010" & @CRLF & _
"2017 trip" & @CRLF & _
"Old photos from 2001" & @CRLF & _
"Old 2002 photos" & @CRLF & _
""
Local $sSubst = "$2 $1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)