using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?) ?\b(\d{4})\b(.*?)$";
string substitution = @"$2 $1$3";
string input = @"Visiting relatives 2010
2017 trip
Old photos from 2001
Old 2002 photos
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}