using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"yourtext(?=(?:[^'\""]*(?:'|\"")[^'\""]*(?:'|\""))*[^'\""]*$)";
string substitution = @"-------";
string input = @"sada yourtext 'yourtext ' ""yourtext uud"" yourtext";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}