#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?:\/\/)?wa\.me\/\d{3,15}"
Local $sString = "https://wa.me/29483294837?text=" & @CRLF & _
"" & @CRLF & _
"text=I'm%20interested%20in%20your%20car%20for%20sale" & @CRLF & _
"https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale" & @CRLF & _
"https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale" & @CRLF & _
"https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale" & @CRLF & _
"https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale" & @CRLF & _
"https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale" & @CRLF & _
"https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")