import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/)?wa\\.me\\/\\d{3,15}";
final String string = "https://wa.me/29483294837?text=\n\n"
+ "text=I'm%20interested%20in%20your%20car%20for%20sale\n"
+ "https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
+ "https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
+ "https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
+ "https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
+ "https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
+ "https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}