const regex = /(?:https?:\/\/)?wa\.me\/\d{3,15}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?wa\\.me\\\/\\d{3,15}', 'gm')
const str = `https://wa.me/29483294837?text=
text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}