import re
regex = re.compile(r"(?:https?:\/\/)?wa\.me\/\d{3,15}", flags=re.MULTILINE)
test_str = ("https://wa.me/29483294837?text=\n\n"
"text=I'm%20interested%20in%20your%20car%20for%20sale\n"
"https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
"https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
"https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
"https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
"https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale\n"
"https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")