re = /(?:https?:\/\/)?wa\.me\/\d{3,15}/m
str = 'https://wa.me/29483294837?text=
text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/2948d3294837?text=I\'m%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837text=I\'m%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/226495150463435?text=I\'m%20interested%20in%20your%20car%20for%20sale'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end