use strict;
my $str = 'bcl-2 was detected in 45% bcl-6 was not detected
bcl-2 was not detected bcl-6 was detected in 45%
no evidendce of bcl-2 bcl-6 was detected in 45%';
my $regex = qr/\bbcl-2\b(?:(?!\bbcl-\d|\bnot\b).)*?\bdetected\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}