use strict;
my $str = '1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100';
my $regex = qr/\b|(?<=\W)(?=\W)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";