import Foundation
let pattern = #"\b|(?<=\W)(?=\W)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)