# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:([^BFGJKPQVWXYZ\W]{3})|([A-Z]{3}))\b"
test_str = ("THE 53097401461\n"
"OF 30966074232\n"
"AND 22632024504\n"
"TO 19347398077\n"
"IN 16891065263\n"
"A 15310087895\n"
"IS 8384246685\n"
"THAT 8000768228\n"
"FOR 6545282031\n"
"IT 5740085369\n"
"AS 5700645258\n"
"WAS 5502713968\n"
"WITH 5182797249\n"
"BE 4818864785\n"
"BY 4703106084\n"
"ON 4594521081\n"
"NOT 4522732626\n"
"HE 4110457083\n"
"I 3884828634\n"
"THIS 3826060334\n"
"ARE 3700433333\n"
"OR 3667713965\n"
"HIS 3611377789\n"
"FROM 3469207674\n"
"AT 3413452256\n"
"WHICH 3140226612\n"
"BUT 2792350185\n"
"HAVE 2777439117\n"
"AN 2726250863\n"
"HAD 2616021603\n"
"THEY 2462131290\n"
"YOU 2337737641\n"
"WERE 2270487439\n"
"THEIR 2152980325\n"
"ONE 2148983086\n"
"ALL 2062779102\n"
"WE 2057296224")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.