import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{L}0-9_.-]+@[0-9\\p{L}.-]+\\.[a-z.]{2,6}\\b";
final String string = "Please email us at: some@example.com. You can also mail us at some@example.co.uk. Etc... hello@åä-ö.com\n"
+ "example@so.il.uk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}