re = /^UPLOAD\|(?'name'.+)\|(?'label'.*)\|(?'required'REQUIRED)?$/m
str = 'UPLOAD|d|dd|REQUIRED'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end