#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*(idMatches):\n(?s)(.+?)(Close: )(?s)(.+?)$"
Local $sString = "<ENG6_6701>" & @CRLF & _
"idMatches:" & @CRLF & _
"" & @CRLF & _
"Close: ENG6_6701" & @CRLF & _
"" & @CRLF & _
"<ENG6_7211>" & @CRLF & _
"idMatches:" & @CRLF & _
"" & @CRLF & _
"Close: ENG6_7211" & @CRLF & _
"" & @CRLF & _
"<ENG6_4474>" & @CRLF & _
"idMatches:" & @CRLF & _
"04\B\_3\IFM_2017.30_App.CrashMonitor.CrashMonitor:11098: <testcase name="SysRS_3104_row 1" type="1" id="11177" foreign_id="0" testdata_id="1073741963" state_mask="0x1100" testcase_number="8" child_count="1" description="ENG6_4474" specification="" comment="" uuid="c0a39548-d902-4a76-b986-3f0c49e7f8b1" testitem_state_mask="0x80" usercode_state_mask="0x00" last_modified="1587729309934" last_synchronized="0">" & @CRLF & _
"04\B\_3\IFM_2017.30_App.CrashMonitor.CrashMonitor.tmb:11098: <testcase name="SysRS_3104_row 1" type="1" id="11177" foreign_id="0" testdata_id="1073741963" state_mask="0x1100" testcase_number="8" child_count="1" description="ENG6_4474" specification="" comment="" uuid="c0a39548-d902-4a76-b986-3f0c49e7f8b1" testitem_state_mask="0x80" usercode_state_mask="0x00" last_modified="1587729309934" last_synchronized="0">" & @CRLF & _
"04\G\0\IFM_2017.30_App.CrashMonitor.CrashMonitor.CrashMonitor_Main.script:645: ENG6_4474" & @CRLF & _
"06\05\EE\IFM_2017.30_App.CrashMonitor.CrashMonitor:10507: <testcase name="SysRS_3104_row 1" type="1" id="4573" foreign_id="0" testdata_id="1073741963" state_mask="0x5B00" testcase_number="37" child_count="1" description="ENG6_4474" specification="" comment="" uuid="c0a39548-d902-4a76-b986-3f0c49e7f8b1" testitem_state_mask="0x80" usercode_state_mask="0x00" last_modified="1587560383700" last_synchronized="0">" & @CRLF & _
"06\10\00\Crasmonitor\IFM_2017.30_App.CrashMonitor.CrashMonitor.CrashMonitor_Main.script:220: ENG6_4474" & @CRLF & _
"" & @CRLF & _
"Close: ENG6_4474" & @CRLF & _
"" & @CRLF & _
"<ENG6_4475>" & @CRLF & _
"" & @CRLF & _
"NOTE: it was needed to change the first \n for a \r"
Local $sSubst = "\t<\1>\n\t\t\2\t</\1>\n</\4>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)