const regex = /@([0-9\.]+),([0-9\.]+),([0-9z]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@([0-9\\.]+),([0-9\\.]+),([0-9z]+)', '')
const str = `https://www.google.fr/maps/place/Avenue+du+G%C3%A9n%C3%A9ral+Leclerc,+Vand%C5%93uvre-l%C3%A8s-Nancy/@48.6602046,6.1612375,17z/data=!4m2!3m1!1s0x47949883998f2a0d:0xb3a20a525afff3a8
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}