import re
regex = re.compile(r"http:\/\/(www\.[a-z0-9]+([\-\.][a-z0-9]+)*\.[a-z]{2,5})(:[0-9]{1,5})?(\/.*)?$|^(\/.*)", flags=re.MULTILINE)
test_str = ("http://www.google.com\n"
"/~germain/CS4480\n"
"http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1\n"
"http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1\n\n"
"http://www.cs.utah.edu:8080/~germain/CS4480\n\n"
"http://www.cs.utah.edu/~germain/CS4480")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")