$re = '/^[a-zA-Z]+([.-]?[a-zA-Z0-9])*@([\w-]+\.)+([A-Za-z]{2,4})+$/m';
$str = 'validandodominiopodesim@pode.sim
validandodominiopodenao@pode.nao
a@pode.sim
variasletras@pode.sim
ComMaiusculaS@pode.sim
0numeronocomeco@pode.nao
numeronofinal0@pode.sim
com0varios1numeros2@pode.sim
com-varios-hifens@pode.sim
-hifennocomeco@pode.nao
hifennofinal-@pode.nao
dois--hifens@pode.nao
com.varios.pontos@pode.sim
.pontonocomeco@pode.nao
pontonofinal.@pode.nao
dois..pontos@pode.nao
com_sublinhado@pode.nao
_sublinhadonocomeco@pode.nao
sublinhadonofinal_@pode.nao
com.ponto-e-hifen@pode.sim
com-hifen-e.ponto@pode.sim
mas.-seguidos@pode.nao
mas-.seguidos@pode.nao';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);