package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([^)]*\)|\[[^\]]*\]`)
var str = `1. The (quick) brown [fox]
2. The (quick) (test) brown [fox] [more] (test) [test][test]
3. The (quick) brown [fox] The (quick) brown [fox] The (quick)
brown [fox] The (quick) brown [fox]
4. Hopefully, you [don't) have cases like (this].
5. Or this: (nesting (like this), need update to regex).
6. Or heterogeneous mixing: (Test [condition] )
If you have conditions 4, 5, 6. Please update your question!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}