%the literal % (3710 / 458 / 2516)
*repeats the group contents below any number of times:
Character Class[a-zA-Z-_] a-zone character from a (9710) to z (12210) (case sensitive)
A-Zone character from A (6510) to Z (9010) (case sensitive)
-the literal - (4510 / 558 / 2D16)
_the literal _ (9510 / 1378 / 5F16)
\s?optionally matches any whitespace character
\{the literal { (12310 / 1738 / 7B16)
*matches any number of characters from the set below:
\sany whitespace character
,the literal , (4410 / 548 / 2C16)
\na line-feed (newline) character (ASCII 10)
.*?any character, repeated any number of times
\na line-feed (newline) character (ASCII 10)
\}the literal } (12510 / 1758 / 7D16)
\s*any whitespace character, repeated any number of times
\na line-feed (newline) character (ASCII 10)
g modifier: global. Finds all matches instead of stopping after the first
s modifier: single line. Allows a dot to match line terminators