const regex = /%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%([a-zA-Z-_])*\\s?\\{[\\s,]*\\n(.*?)\\n\\}\\s*\\n', 'gs')
const str = `%abstract-class {
font-family: Verdana;
}
%abstract-class {
font-family: Verdana;
}
%abstract-class{
font-family: Verdana;
font-site: 100%;
}
bla {
lkdjkjd: 10px;
}
%abstract-class {
.abstract-class {
font-family: Verdana;
}
a,
a:hover {
}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}