import re
regex = re.compile(r"%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n", flags=re.DOTALL)
test_str = ("%abstract-class {\n"
" font-family: Verdana;\n"
"}\n\n"
"%abstract-class {\n"
" font-family: Verdana;\n"
"}\n\n"
"%abstract-class{\n"
" font-family: Verdana;\n"
" font-site: 100%;\n"
"} \n\n"
"bla {\n"
"lkdjkjd: 10px;\n"
"}\n\n"
"%abstract-class {\n"
" .abstract-class {\n"
" font-family: Verdana;\n"
" }\n"
" a,\n"
" a:hover {\n\n"
" }\n"
"} \n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")