using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tag1[^>]*>(.*?)<\/tag1>";
string input = @"<tag>
<tag1 class=1>data1</tag1>
<tag2 class=2>data2</tag2>
<tag1 class=3>data3</tag1>
</tag>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}