$re = '/<tag1[^>]*>(.*?)<\/tag1>/';
$str = '<tag>
<tag1 class=1>data1</tag1>
<tag2 class=2>data2</tag2>
<tag1 class=3>data3</tag1>
</tag>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);