#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:11|111)$(*SKIP)(*F)|.+"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"00" & @CRLF & _
"01" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"000" & @CRLF & _
"001" & @CRLF & _
"010" & @CRLF & _
"011" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"110" & @CRLF & _
"111" & @CRLF & _
"0000" & @CRLF & _
"0001" & @CRLF & _
"0010" & @CRLF & _
"0011" & @CRLF & _
"0100" & @CRLF & _
"0101" & @CRLF & _
"0110" & @CRLF & _
"0111" & @CRLF & _
"1000" & @CRLF & _
"1001" & @CRLF & _
"1010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")