# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=\# ?\d+\.)"
test_str = ("# This is a comment <-beacuse it starts at the begining of the file\n"
"# This is a comment <- see above\n"
"# 1. Item one <- not a comment because it starts with 1.\n"
"# Description of Item 1 <- not a comment as it is after a line that starts with a number\n"
"data point 1\n"
"data point 2\n"
"data point etc\n"
"3 <-- represents number of data points under Item one\n\n"
"# 2. Item two <-- not a comment\n"
"# Description of item 2 <-- not a comment\n"
"data point 1\n"
"data point ..\n"
"data point 100\n"
"100\n"
"#3. Item three <--- not a comment\n"
"# Item three description\n"
"0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.