using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|<h3>(.+?)</h3>|<h4>(.+?)</h4>)";
string input = @"<h3>foo</h3>
<h4>bar</h4>
<h3>title</h4>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}