const regex = new RegExp('(?|<h3>(.+?)</h3>|<h4>(.+?)</h4>)', 'gs')
const str = `<h3>foo</h3>
<h4>bar</h4>
<h3>title</h4>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}