// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(?|<h3>(.+?)</h3>|<h4>(.+?)</h4>)").unwrap();
let string = "<h3>foo</h3>
<h4>bar</h4>
<h3>title</h4>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}