import Foundation
let pattern = #"^\s*\bMAIN LEVEL\b\n(?:(?!\n\n)[\s\S])*\bBedrooms:\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MAIN LEVEL
Entrance: 11
Living: 22
Dining: 333
Kitchen: 444
Family: 555
Bedrooms: 666
Den: 777
SECOND LEVEL
Entrance: 1111
Living: 2222
Dining: 3333
Kitchen: 4444
Family: 5555
Bedrooms: 6666
THIRD LEVEL
Entrance: 3333
Living: 334
Dining: 3332
Kitchen: 33336
Family: 33332
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)