use strict;
my $str = '>123<
123-
123
abc123def
abc1234def
12345
jkfjg2342395
kdjfd 23423
ที่ 20025-28
ที่ 2002528
ที่a20025a28
ที่ 20025-28';
my $regex = qr/(\b)(\d{5})(\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}