using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\$?[0-9]+(?>,[0-9]{3})*(?>\.[0-9]{2})?(?(1)\))$";
string input = @"$1,024.12
15683.33
$15,683.33
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}