# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(aaa)|(bbb)|(ccc)/\2\1\3/gm;t' <<< "aaa
bbb
ccc
aaa
bbb
ccc"