#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(aaa)|(bbb)|(ccc)"
Local $sString = "aaa" & @CRLF & _
"bbb" & @CRLF & _
"ccc" & @CRLF & _
"" & @CRLF & _
"aaa" & @CRLF & _
"bbb" & @CRLF & _
"ccc"
Local $sSubst = "\2\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)